Back
Maintenance

Changing the Gamehosted Panel
Completed 19 Feb at 10:30am CET.
panel.gamehosted.net
Completed
Maintenance completed
Posted
19 Feb at 10:30am CET.

Started
We will be changing and updating our Gamehosted Panel, this will not impact any game servers but can prohibit access to our panel for up to 5 minutes.
Posted
19 Feb at 10:00am CET.